Mac Troubleshooting

Discussion in 'Tech Support' started by Senshu, Mar 17, 2014.

  1. EtnaD1982

    EtnaD1982 New Member

    I made it, i upgrade my osx to maverick and now it works :)
    Moglieone likes this.
  2. EtnaD1982

    EtnaD1982 New Member

    BTW i cannot find a good resolution... wit the automatic full windowed i cannot see the stats of the champs and with the other is even worst... and the audio is terrible... will Greens do something?

    KTCAOP I need me some PIE!

    Can you post a screenshot? I wonder if it is due to the resolution of the game and/or the computer.

    And why are the complaints about the audio?
  4. EtnaD1982

    EtnaD1982 New Member

    This how i see the battle ground (it is in low quality).

    And audio... i can't hear the sound effect when i move a champ, all effect are very low except when i conquer a font.

    Attached Files:


    KTCAOP I need me some PIE!

    Is it that the sound effects perhaps in your preferences are set low? Though the font capture sound seems to work independently and is always really, really loud >_<.

    How is the window'd version of the game? Full Screen in general I think has been giving various people issues, this is the first complaint that I can remember of this kind, however, thank you for the upload!
  6. Moglieone

    Moglieone Well-Known Member

    Confirmed. However, I'm yet to have any of your problems. Mine is working perfect
  7. Senshu

    Senshu Administrator Octopi

    What is your default screen resolution? Try going into your computer's settings and select a different screen resolution and see if that allows you to see the bottom portion of the game screen.
  8. Senshu

    Senshu Administrator Octopi

    A new tip has been added to the original post. Try placing your Dock at the bottom of the screen if you haven't already.
  9. Demthedark

    Demthedark The King of Potatoes

    I upgraded to Maverick. Progress was made. Now im getting this message

    "Connection lost or unavailable. Please check your connection and try again. When the connection is repaired, the Pox Nora Launcher will attempt to resume where it left off."

    Im connected to the internet obviously, did anyone else run into this problem?
  10. singinsammy

    singinsammy Member

    i got something like this once i upgraded; try reloading the app from the server. that fixed it for me. had to go through an update
  11. realgigio

    realgigio New Member

    I am a brand new Mac user, so after years of pc I am struggling a bit to get used to the usual differences in OS

    The problem is that I am unable to even start pox...on steam it says that pox is not meant to run on my platform, and if I directly download pox from the website then I am unable to run it because "the identity of the developer cannot be confirmed" (I just bought this 15" retina macbook pro, so I have the newest OS - edit: OS X Yosemite)

    Any help? thanks!!
    Last edited: Mar 9, 2015
  12. Senshu

    Senshu Administrator Octopi

    Ah, unfortunately the version of Pox Nora on Steam is only the Windows version. You will need to download the stand alone version to play on a Mac.
  13. iowa90

    iowa90 New Member

    Process: JavaAppLauncher [8736]
    Path: /Applications/
    Identifier: com.poxnora.launcher.Main
    Version: 1.0 (1)
    Code Type: X86-64 (Native)
    Parent Process: ??? [1]
    User ID: 501

    Date/Time: 2015-05-15 02:54:17.386 -0500
    OS Version: Mac OS X 10.8.5 (12F45)
    Report Version: 10

    Above is the error I get once I log onto the game. It will last around 20 seconds before doing this. Thoughts?
  14. plomps

    plomps New Member

    I'm completely new to PoxNora, and due to my problem I'm still yet to have my first taste, but it sounds like my kind of game so I'm going to persevere. I've downloaded the client, the patcher has downloaded all the files. When I press restart after the patcher finished downloading, the patcher crashed showing the little loading circle and I'm forced to force quit.

    When I restart the launcher and press play the game completely fails to load. I simply press play, the launcher disappears and nothing happens. I've tried reinstalling, the repair button and waiting. I'm having no joy. Can someone please give me some advice on what steps I should take next? Or am I doomed to play the ubiquitous chess app for the rest of my days?

    Incase it's of any help, I'm on a 2015 Macbook Pro with the Yosemite OS and I'm running Java version 8 update 51.

    Right now when I try to launch the game even the launcher won't launch. I briefly see the logo pop into the dock then it dies. Thanks in advance for any help!
  15. Senshu

    Senshu Administrator Octopi


    It is hard to say what is causing your problem based on your description. Our first suggestion would be to completely uninstall Pox Nora, and before you reinstall make sure all your computer's drivers are up to date.

    To Uninstall:
    • Go to your Pox Nora directory.
    • Then click on Uninstall
    • After uninstalling and before reinstalling the game, delete the Pox Nora folder if it is still in the Desert Owl Games directory.
    • Then download and install the game from
    Note: you may need to use the program AppCleaner to make sure all files are removed before reinstalling.

    From your description and that you are using a new Mac that there is a software conflict. You may need to look around the web to see if there are any programs you have installed that could be interfering with Java based programs. It could be security software is killing the application before it can launch because it does not recognize the application.
  16. Fentum

    Fentum I need me some PIE!

    @Senshu my old PC has now given up and I still can't run Pox on my shiny Mac. I had this issue a few months ago but have been using the old PC. Now I can no longer play Pox. I am completely untechnical as I am a board game player mostly.

    The Mac updated Pox, looked good then quit from the launchpad with the message 'Main quit unexpectedly'. I got a massive log but it is too long to post here. I am on 10.8.5 OS, whatever that means.

    "Help me Senshu. You're my only hope."
    Last edited: Sep 20, 2015
  17. Senshu

    Senshu Administrator Octopi

    Hi Fentum,

    The best place to address something like this is through our customer service system. Go to and click on Help. Then create a customer service ticket that describes exactly what you are doing and where exactly the problem is occurring and what error message if any you are getting e.g. Can't install game, hit Play Now and nothing happens, etc. Please also provide your full computer specifications.
  18. Fentum

    Fentum I need me some PIE!

    I think I'll just stop. It's too technical for me.
  19. Senshu

    Senshu Administrator Octopi

    Without looking into it there isn't much we can do in the event there is a problem with the client itself. We would like to make sure you could play. One of the unfortunate things about Macs is that despite how user-friendly they are supposed to be when there is a problem trouble shooting can be a lot more difficult.

    If you provide where in the process of Installing and Launching the game the problem occurs that will help narrow down what may be causing this to happen. Also, on Macs there is always the option of installing Windows as a secondary operating system.
  20. Fentum

    Fentum I need me some PIE!

    The problem occurs immediately when I press create game from the battlegrounds page. Unranked.

Share This Page