Mac Troubleshooting

Discussion in 'Tech Support' started by Senshu, Mar 17, 2014.

  1. Senshu

    Senshu Administrator Desert Owl Games

    If you are having issues with getting Pox Nora running then these solutions may help. We will update this list as new solutions are discovered or posted by players.

    If you have a trouble shooting tip for a problem that has been reported regarding Mac Users please post here.

    First thing you should always try when you experience a problem is to open the launcher, click on options, and hit repair.

    Tip #1
    Updating to Newer Mac OS

    Pox Nora is currently running on Java 7 which is not supported by Mac OS versions older than 10.7. If you are unable to get Pox Nora to run and are using Mac OS 10.6.8 or older consider upgrading to a newer version. Currently upgrading to Mac OS Mavericks is free.

    To Upgrade:
    • Click the Mac App Store icon.
    • Find OS X Mavericks.
    • Click “Download”
    Tip #2
    Some problems can be the result of corrupt game files. There are two options to resolve this problem, one is to use the repair option and the other is to uninstall and reinstall Pox Nora.

    To Repair:
    • Open the Pox Nora launcher by clicking on the [​IMG]
    • Click on Options [​IMG]
    • Click Repair.
    To Uninstall:
    • Go to your Pox Nora directory.
    • Then click on Uninstall
    • After uninstalling and before reinstalling the game, delete the Pox Nora folder if it is still in the Desert Owl Games directory.
    • Then download and install the game from https://www.poxnora.com/download.do
    Note: you may need to use the program AppCleaner to make sure all files are removed before reinstalling.

    Tip #3
    Connection Lost or Unavailable:
    This error is given when the downloaded application has not been placed into the application folder with the "Finder" function of Mac.

    Note: This solution only works for Mac OS 10.7 and above with Java 7 installed.

    Please follow these steps for a swift resolution

    1. Download Pox Nora.
    2. Open "Finder" application from bottom bar.
    3. Click where it says PoxNora under the "Devices" sub menu towards the left hand extreme of the "Finder" window.
    4. Now towards the top of the window you should have the "Device" called "Poxnora" open so it should show 2 new icons:
    Applications
    PoxNora (this time next to the blue recognisable PoxNora Icon upload_2014-3-17_12-47-47.png )
    5. Click and drag that PoxNora+Icon into where it says "Applications" on the far left hand side of the Finder window. (it may work to click and drag it instead into the "Applications" word immediately above it as well but I did it the other way)
    6. It may prompt you to over-write the old version and give you options to either
    "keep both"
    "stop"
    >"REPLACE"< (Psst, you want this one)
    Click "Replace"

    Thanks to Tommybee for providing this trouble shooting tip.

    Tip #4
    Bottom of the game screen is being cut-off

    If you are having a problem with the bottom of the game screen being cut-off when running in fullscreen mode this may be a result of where you have your dock located. Try moving your dock to the bottom of your screen or a different location.

    Thanks to RedDain for discovering this trouble shooting tip.

    Tip #5
    If you are getting a warning "The developers identity can not be recognized" that is preventing you from installing or launching the game try holding down control while launching the game.

    Tip #6
    If you are having difficulty using the Right Click because you are on a mac laptop this guide should help you come up with a work around http://www.wikihow.com/Right-Click-on-a-Mac

    Tip #7
    If your Mac won't open up the install file you should try opening the install file as root user. Apple has a comprehensive guide on how to open files as a root user: https://support.apple.com/en-us/HT204012
     
    Last edited: Oct 5, 2015
  2. RedDain

    RedDain I need me some PIE!

    I can do all of the above, and when I double click the icon copied into my Applications folder, it gives me the same "JavaAppLauncher quit unexpectedly" error...
     
    singinsammy likes this.
  3. dezigeuner

    dezigeuner New Member

    this is just an insoluble issue, unless you didn't migrate to 10.7 and above and update you JVM, as well, if look inside the poxnora package, under 'contents' section you may found a 'java' directory and if you trying to launch an xlauncher.jar you may be advised to update your actual Java whihc leads you upon the java site where you can read everything enclosed to this regard.
    Game devs must pay tighter attention to compatibility, because for me now (and I played PN from its very start in 2008 app. year) - the actual game appears to be completely spoiled and unplayable.
    so i left it for good. Game is for pleasure not to fcuk the player's brain away with a programmers riddles.
     
  4. Comissar

    Comissar I need me some PIE!

    This is what happens for me, as well.
     
  5. RedDain

    RedDain I need me some PIE!

    I've done some digging around and have found that the problem lies in the fact that the game was compiled using Java versions later than any that run on OS 10.5 up to 10.6. Seems like there is really no solution except upgrading OS, unless DOG is willing to recompile legacy versions.

    I may be wrong about this: my programming skills are rudimentary. But the nature of the error code "dyld: unknown required load command 0x80000022" indicates that the compilation was done with much newer SDKs and commands.

    According to what I have read, it looks like compiling (i.e. on the server side, by DOG programmers) with the option "-mmacosx-version-min=10.5" might get rid of the problem... however, the stuff I was reading was from 2012, so even that might be outdated.

    On a personal note, I am wondering which versions of OSX are actually able to run the App, so that I know what to shoot for when I upgrade (which I do need to do anyway, unfortunately)... the world of planned obsolescence is depressing.
     
    Last edited: Mar 18, 2014
    bzodiac likes this.
  6. chthuud

    chthuud The King of Potatoes

    Today's big patch did nothing to address the failure to launch problem, which is disheartening. I'm beginning to think those of us with older Mac OS's are out of luck. I think Mavericks (10.9) is a free upgrade, and as far as I know, the client actually works on it. I'd rather not upgrade to Mavericks as I've heard it doesn't run well on older model Macs, which I am using. So I'm just going to wait on word from the devs about this problem.
     
  7. Senshu

    Senshu Administrator Desert Owl Games

    We haven't had time to address the Mac Problem yet. As RedDain said it may be a result of version of Java being used, in which case we will need to determine how to best address this.
     
    bzodiac likes this.
  8. bzodiac

    bzodiac New Member

    Process: JavaAppLauncher [222]
    Path: /Applications/PoxNora.app/Contents/MacOS/JavaAppLauncher
    Identifier: com.poxnora.launcher.Main
    Version: ??? (???)
    Code Type: X86-64 (Native)
    Parent Process: launchd [90]

    Interval Since Last Report: 145606 sec
    Crashes Since Last Report: 10
    Per-App Interval Since Last Report: 0 sec
    Per-App Crashes Since Last Report: 10

    Date/Time: 2014-03-19 12:48:46.834 -0600
    OS Version: Mac OS X 10.5.8 (9L31a)
    Report Version: 6
    Anonymous UUID: 1E43548C-DC23-4FA7-A50A-F214A0F29E93

    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Crashed Thread: 0

    Dyld Error Message:
    unknown required load command 0x80000022
     
  9. RedDain

    RedDain I need me some PIE!

    bzodiac, same error here. I've done a lot of searching and looking, and it's basically that the version of Java they used for compiling the application is newer than the version supported on 10.5.8 (and 10.6.x)... different commands and protocols, no fix unless they recompile for backward compatibility (it is possible) or you get an OS upgrade.

    :(
     
    bzodiac likes this.
  10. KTCAOP

    KTCAOP The King of Potatoes

    I've heard of some issues on Mavericks, though no issues with Lion and Mountain Lion, for those that are looking to upgrade, though I do hope that backwards compatibility will be able to be put into place as I can understand some people are reluctant to upgrade.
     
  11. singinsammy

    singinsammy Member

    @RedDain @bzodiac

    My issue is the same. I've cleared java preferences, restarted the computer in safe mode, fiddled with the firewall and nothing helps. If you're right, reddain, I'm actually willing to upgrade my OS-god I hope it's not expensive-but I'm concerned that my computer is a little old. I'm pretty bummed to be going on 3weeks without my favourite game
     
  12. RedDain

    RedDain I need me some PIE!

    Upgrading from 10.5 to 10.6 requires an actual dvd. You can order it online or you can get it at an apple store (19 dollars US). The upgrades from 10.6 through 10.8 are available once you've gotten to 10.6 ... As long as you have an Intel Mac, you should be able to handle all the upgrades.... if you've got a PPC mac, you're out of luck.
     
  13. singinsammy

    singinsammy Member

    Can you confirm that the OS and java upgrades will actually make the game run? Or are we thinking wishfully?

    Thanks,
    Sam
     
  14. RedDain

    RedDain I need me some PIE!

    I am under the impression that 10.6 does not work, but that 10.7 does. So if you upgrade from 10.5 to 10.6 (via dvd) and then from 10.6 to 10.7 (via download). And then upgrade Java and etc, the game should work.
     
  15. KTCAOP

    KTCAOP The King of Potatoes

    I have not seen any reports of any problems with 10.7 posted on the boards. But yeah, it also is dependent if your mac is able to upgrade to 10.7
     
  16. EtnaD1982

    EtnaD1982 New Member

    I habe the same problem. OSX 10.6.
    I upgraded my java but it still doesn't work...
     
  17. singinsammy

    singinsammy Member

    I upgraded my OX to 7.3, then upgraded my Java to 7, and now it's working. I think RedDain was right, and that the new game was written using Java no longer supported by older versions
     
  18. RedDain

    RedDain I need me some PIE!

    Got to go to 10.7 and above, and Java 7... I will be doing this soon, and will report.
     
  19. EtnaD1982

    EtnaD1982 New Member

    No, i upgraded to 10.8, java 7 and nothing... now i'm trying to upgrade to osx maverick, let's wait...
     
  20. rorytufano

    rorytufano The King of Potatoes

    This is getting beyond a joke now. Any other game that expects to stay afloat would fix bugs like this that are alienating a fairly large portion of their customers.

    Can we please get a definitive fix for this?
     

Share This Page