The game doesn't load ranked play

Discussion in 'Tech Support' started by wrathpact, Jul 18, 2017.

  1. wrathpact

    wrathpact The King of Potatoes

    PC Info:

    Windows 7
    Core i3 3.1 GHz
    RAM 4GB
    64 bit

    I can launch the game (Steam), login and stuff. The game doesn't crash or anything.

    Everytime I go for "Ranked Play" or "Solo Play", it just keeps "Validating Deck" or trying to load, and never stops. I can back and try again, but it repeats.

    Also, when I try to close/exit the game, it crashes.

    I'll try to reinstall it now, and will update here if anything changed.

    Sorry for bad english.
     
    Excalibur95 likes this.
  2. Excalibur95

    Excalibur95 The King of Potatoes

    i just started getting this problem in the last 12 hours roughly. never had it before.

    usually i can get one solo game in, it completes, get back to lobby go to either solo or ranked and the busy rotating orb stays and it never loads. i then press x top right to close client, it says not responding and i have to force close it.

    this is happening every time now -major bug, that wasnt there before and i was able to play tons of solo games in a row.
     
  3. wrathpact

    wrathpact The King of Potatoes

    After reinstalling the game, the same still happened, but I realized it may happen because I open the options and change it to a higher resolution and to fullscreen before doing anything else.

    When I just logged in and opened the ranked play, it loaded normally. I discovered that because my friend said it worked for him (it was on his pc).

    Don't know if it's happening the same thing for you.
     
  4. Excalibur95

    Excalibur95 The King of Potatoes

    this is still happening for me but intermittent.

    sometimes closing the client forcefully and restarting fixes the issue othertimes not.
     

Share This Page